disgruntled6661's profile

New Poster


1 Message

Wed, Sep 16, 2020 7:00 PM

Xfinity throttling internet speeds consistently since Covid pandemic

I have been one of the tech employees in SF Bay area, working from home since pandemic and to my chagrin I've had the worst WiFi speed issues since pandemic. Been with customer services for hours and hours, spent hours and days troubleshooting, tried 2 brand new high speed modems, a brand new, top of the line, highly rated dual band router all to no avail! 

Upgraded to 200 Mbps which has been a total waste as we don't even get 30 Mbps most of the time! So I suggest that no one upgrade their service and Xfinity not charge us or put under contract for the services they can't provide. 

I also have proof that you're throttling because as soon as I installed the new router it shot up to 178 Mbps for a few minutes immediately and as soon as you have found out, throttled it back to 30 MBps again! I tried multiple third party speed tests and they are consistent low speed and much worse during working hours when it matters the most! There are at times it is even less than 1Mbps (as in ancient dial up modem speed)!!! when we're paying for 200 MEGA bps (200 times less!!) which is unbelievable!! 

I would rather not downgrade becauase I do want the higher speed to be efficiently working from home and would rather cancel instead since you haven't kept your part of the contract to give the speed that is being paid for and keep throttling the speed. All my teammates at work who are having xfinity are complaining about this issue and our IT suggested clearly that you're throttling it and have my service canceled as company is now involved with WiFi services due to WFH. 

"Customer support" doesn't help whatsoever what I found is they will say we have reset and check back after several days that way you will forget and call us back. So I have to keep repeating that cycle. I have already done that about 10-15 times so I asked to escalate and the customer service agent said her boss is not available! 


No Responses!

New to the Community?

Start Here