amyr137's profile

Regular Visitor

 • 

3 Messages

Sun, Dec 13, 2020 2:00 PM

Jumpy/glitchy channels

Ongoing issue with glitchy channels on pretty much any station that isn’t a premium network which we pay for. Have restarted and re-set modem more than once and it doesn’t fix it

Responses

Rustyben

Expert

 • 

24K Messages

5 m ago


@amyr137 wrote:
Ongoing issue with glitchy channels on pretty much any station that isn’t a premium network which we pay for. Have restarted and re-set modem more than once and it doesn’t fix it

what you are describing sounds like picture pixelation (breaking up). that usually needs a tech to determine if signal is OK outside of your home.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Official Employee

 • 

184 Messages

5 m ago

I appreciate you having tried to reset the modem already! We'd like to look into this further; please click on my handle (ComcastGina) and send a private message with your name, and service address so we can take a look at the signal data and equipment, to start. 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here