Jeffery_71's profile

Frequent Visitor

 • 

5 Messages

Wed, Oct 14, 2020 7:00 AM

Can't get ON DEMAND

When I click the ON DEMAND button on my remote, I get "this option is not avaiable.  Please try again later or unplug the power to your X1 box for one minute.  after a minute plug the power cable back in.  Visit Comcast.com/help for more info Error (CL-17)".  All cables are tightly secured to the cable box and outside in the box on the house. 

 

I have unplugged my box at least 4 times on my own and it has not fixed the issue.  I have called the Xfinity support line and they are useless.  It appears like they are reading from a script and having me do the same things over and over.  The issue is never fixed.  

 

When I look at the status page on Xfinity website my X1 TV shows not connected.  I click on the reset button and after clicking through a few screen it message come back "Can't Connect to X1 TV box" 

 

Need some help from someone.  Still waiting for a Support supervisor to  call me.  I doubt that will happen.  

Responses

CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

8 m ago

Kind of odd the error message is for a legacy box not an x1 box, what’s the model of your box? And X1 remotes don’t have an On Demand button

Frequent Visitor

 • 

5 Messages

8 m ago

Model PR150BNM

 

The On Demand button is on the remote not on the X1 Cable box.  

Again

Expert

 • 

25.8K Messages

8 m ago


@Jeffery_71 wrote:

Model PR150BNM

 

The On Demand button is on the remote not on the X1 Cable box.  


CCAndrew wrote: And X1 remotes don’t have an On Demand button 

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Frequent Visitor

 • 

5 Messages

8 m ago

Ok, it the Xfinity button on the remote. But it doesn't matter because on demand doesn't work. Quit replying with things that don't help
CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

8 m ago

Quit replying with things that don't help
__________
Post correct information and we won’t. The model you posted is not an X1 box
ComcastChe

Official Employee

 • 

6.1K Messages

8 m ago

Hi @Jeffery_71

Thanks for posting to the Xfinity Forum to get help with the issue you're having when attempting to access On Demand. I'm sorry you have yet to be contacted by a supervisor regarding the errors. No need to wait or call back in. We can assist you here.

The questions being asked by the experts on this forum are relevant and the answers will help us determine how to fix your issue. 

As mentioned by @CCAndrew, the code you're receiving is generally only triggered on older model "Legacy" boxes, and the new model X1 Platform remotes don't have an actual "On Demand" button.

To us, this indicates you have the incorrect equipment for the services you're paying for. Can you please confirm the make and model of the box you currently have? 

I'd be happy to chat with you in a private message and fix this so you can get back to enjoying your favorite shows and movies On Demand. Please send me a private message with your full name, as it's listed on the billing statement. Click on my name ComcastChe, then click Send a message. 

 

 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

Frequent Visitor

 • 

5 Messages

8 m ago

I still can't get on demand. Still haven't been contacted by a supervisor. The last time I called the agent created a ticket and said another agent with more troubleshooting tools would call me back. It been at least 4 days and nothing. Getting really frustrated with Xfinity support.

Regular Visitor

 • 

3 Messages

8 m ago

I too get the CL-17 error code for On Demand, using an RNG110 set-top box. Have done all the disconnections of the box several times and still get CL-17 error code. What to do next?

MNtundraRET

Expert

 • 

4.3K Messages

8 m ago

Get the cable-box replaced. Some of the older non-X1 boxes cannot handle ON DEMAND after recent chenges made by Comcast. Your box cannot be updated over the Internet or this code change. You need to get it replaced with one that handles the latest version of code used for ON DEMAND.

 

If you do not choose to pay for Comcast Internet, you cannot use X1 cable boxes.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Frequent Visitor

 • 

5 Messages

8 m ago

The tech support send me a new cable box. The cable box was the exact some as I currently have. I swapped it anyway and had to call to get it activated. I have it plugged into my network and it still doesn't work.

Regular Visitor

 • 

3 Messages

8 m ago

Replaced the RNG110 with the RNG 150N from the Comcast store today , good experience at the Fresno store -  in and out in 5 minutes,  BUT still get the CL-17 error code for On Demand. I guess I wil get on the phone tomorrow morning>

Regular Visitor

 • 

3 Messages

7 m ago

CL-17 finally seems to be fixed, Monday 10/26 replaced old RNG110 with RNG150N, same CL-17 error with On Demand. Tuesday 10/27 chatted with agent online - no resolution, call back from Tech - no resolution. Wednesday and Thursday still CL-17. Thursday 10/29 with another new RNG150N and even worse no channels at all. Tech coming out Friday afternoon.

 

Friday 10/30 Tech arrives at 2 pm. Before he arrived I had taken  a small TV and the RNG150N out to cable box on outside of house - same as inside house no channels and no On Demand. With Tech got chennels back but still CL-17 for On Demand.

 

UNTIL Tech went to street pole and changed noise filter and end fitting on our cable line to the junction box on main cable line. On Demand finally worked! Saturday 10/31 On Demand still working. So it looked like changing noise filter and cable fitting did the job!

sma4

New Poster

 • 

15 Messages

2 m ago

Having similar problem...no On-Demand with  CL-14 Error. No help from xfinity so far. Tech was supposed to come 2 days ago but never showed up (literally waited all day). Thanks for providing resolution. At least, if/when they show up I can offer this solution!

Visitor

 • 

1 Message

2 m ago

I too am getting the CL-17 error message and on demand no longer works. Previous replies from Comcast says to start a chat message, which I cannot find. Was supposed to get a call back, but that never happened. Where do I go for help?

Official Employee

 • 

263 Messages

2 m ago

Hello everyone! If you are getting error messages while trying to access On Demand Programing, please reach out to us directly. More than likely you will need a TV box upgrade, however we can take a look for you! 

 

To reach us directly, please send us a chat message with your first and last name. The Peer to Peer chat icon is located at the top right of the Community Forum page, clicking on the chat icon will allow you to initiate a chat conversation with us directly.

 

Please ensure you are sending your message to our 'Xfinity Support' handle.

 

Thank you!

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

New to the Community?

Start Here