TonyR227's profile

Regular Visitor


1 Message

Mon, May 11, 2020 5:00 PM

Cable Box Died - Need a Replacement

Yesterday (5/10) the amber power light on my cable box light was blinking, but would not come on with the remote. Everytime I would push the "All Power" button, the TV would turn on and off, but the box did nothing. (There is no power or reset button on it) Thinking it just needed reset, I unplugged the power, waited several seconds, and then plugged it back in. Now the light wasn't even blinking. I tried new batteries in the remote, moved the power cord to a different outlet, tried a new cable from the wall outlet to the box, and even switched it with the other adapter box, nothing. I tried using the automated assistant chat line, but that was totally useless as it is only programmed with specific questions and answers. I eventually tried the reset feature through the support line, and that only made the light start blinking again. I tried calling three different support numbers, but it always took me back to the automated voice assistant. which was, again, totally useless. I was finally able to get a live, warm body on the phone, and we went thru the standard checklist of troubleshooting questions. This, of course, did not resolve anything. I mentioned that I would normally have taken the box to my local Xfinity store, but it was closed. She checked neighboring county stores, but they are all closed as well. She then told me that Comcast is currently not doing any service calls, and since the stores are closed there was really no other options. The support person did say that she logged my problem in their system, but I'm sure that I'm still being charged a rental fee for a piece of equipment that no longer works. So my question is, if the stores are all closed, and there are no service calls, how am I supposed to get a replacement box? The serial number of my box is M90705FXUM06.


UPDATE 5/14 So for some god unknown reason, my cable box is back to working 100 percent, but only after switching it with the upstairs box! This started only because I wanted to watch TV downstairs in the mornings, so I brought my upstairs unit down to the family room, and moved the "dead" unit upstairs to the bedroom. After waiting a full day, just out of curiousity, I pressed the All Power button on the formally "dead" unit remote. I couldn't believe my eyes when I saw the power light come on, and the TV had a picture! So now I'm thinking that whatever was causing it not to work before had been cleared, and it was back to normal. I disconnected it, took it back downstairs to the family room, and reconnected it. I pressed the "All Power" button on the remote, and nothing! NO power light, no blinking light, nothing! So begrudgingly I disconnected it and returned it to the upstairs bedroom again. and left for work. The next morning I tried the "All Power" button and voila! Power light comes on and the TV has a picture! And yes, this is all with the same remote (Of course the digital adapter box works no matter where I connect it) This one really has me baffled, but I guess I just need to leave it upstairs. Any former employees out there that could possibly explain why it works upstairs, but not downstairs? (Prior to this it has always been connected and working in the Family Room)


No Responses!

New to the Community?

Start Here