BenTrovato's profile

Frequent Visitor

 • 

5 Messages

Sun, May 10, 2020 4:00 PM

The email program has forgotten my email password and the outgoing servers are not functioning.

I use Apple Mail as my client. In the past the message would send if I changed the outgoing server, but there are no longer any that function. The server that corresponds to the source email address says it is offline. Isn't Xfinity responsible for managing the server and providing me with the passwords? I tried deleting one of the address and then adding it back in, but the process failed

Responses

Frequent Visitor

 • 

5 Messages

1 y ago

When I send email from xfinity connect and receive on xfinity connect the email arrives, but I cannot open it, then it disappears.

Latoque

Expert

 • 

28.8K Messages

1 y ago


@BenTrovato wrote:

When I send email from xfinity connect and receive on xfinity connect the email arrives, but I cannot open it, then it disappears.


Do you have the account ena led on another device using POP3?  If so, it may be downloading the messages and then deleting them from the server.

Frequent Visitor

 • 

5 Messages

1 y ago

Thank you for your response, Latoque. The problem with the disappearing emails has resolved. My greater issue is with receiving emails from the Comcast addresses in my client 'Apple Mail'. The program repeatedly asks for my account password or tells me the outgoing service is not working. My research has suggested that the email password(s) are the same as the Xfinity log-in password. This has not been successful. I have tried the last password chosen for that account and earlier passwords. There is no option to renew the password. Nor am I able to delete the account and then re-add it to the client. Again thanks for any advice. This seems like a pretty basic issue.

Frequent Visitor

 • 

5 Messages

1 y ago

Thank you Carole

CCCarole

Gold Problem Solver

 • 

40.1K Messages

1 y ago

I no longer help in the Forums due to poor health, but I have sent your PM to the Email Expert from the Forums.  He will assist you.  His Username is Latoque..  You can also post your issue right there in the Email Forum for assistance.

Sorry, Carole

Frequent Visitor

 • 

5 Messages

1 y ago

It asks me for the password when I am adding the account. When I fail it stops the process. Since I can send and receive mail from the browser-based email I know the password is available there, but I cannot find it in Safari passwords or in Keychain access. My .mac addresses work fine as I designate iCloud as the outgoing server. One of my comcast.com addresses also works as apparently the proper password is available to the program.

Latoque

Expert

 • 

28.8K Messages

1 y ago


@BenTrovato wrote:

Thank you for your response, Latoque. The problem with the disappearing emails has resolved. My greater issue is with receiving emails from the Comcast addresses in my client 'Apple Mail'. The program repeatedly asks for my account password or tells me the outgoing service is not working. My research has suggested that the email password(s) are the same as the Xfinity log-in password. This has not been successful. I have tried the last password chosen for that account and earlier passwords. There is no option to renew the password. Nor am I able to delete the account and then re-add it to the client. Again thanks for any advice. This seems like a pretty basic issue.


I use Mac Mail too, and I have no problem with it.  Exactly what happens when you try to delete the account and then re-create it in Mail?

New to the Community?

Start Here