Dsb893's profile

New Poster


2 Messages

Sat, Jan 2, 2021 2:00 PM

Invalid server certificate / connection is not private error

After activating a new xfi gateway, we cannot access any website other than the XFINITY website which is very slow. We get ‘connection is not private’ & err_cert_common_name_invalid. I also cannot connect to my work VPN which was connecting fine with the old gateway. I now get an invalid server certificate error.

I saw an old thread on here with the same issue but saw no resolution. And when I added to that thread, a self proclaimed ‘expert’ just stated I needed to start a new thread since it was old thread without offering up any of their ‘expert knowledge’.

Does anyone have any idea what I need to do to fix this mess? Even when I try to access things through their website I get errors as well. I need to get this fixed since I work from home!


Official Employee


2.9K Messages

5 m ago

Greetings, @Dsb893! I appreciate you taking the time to reach out to us here on the forums. I hope you are having an amazing day! I apologize to hear that you are getting these errors since switching over to the new gateway. Usually, these errors occur from the computer side of things. Mainly with the browser. Is the browser you are using been updated lately? Is your system time displaying the correct time and date? Have you tried to browse the internet using incognito mode?

New Poster


2 Messages

2 m ago

Since the android app is going away and I've tried using using connect.xfinity.com/appsuite/#!! I get this too.

android version 4.4.2

chrome version 81.0.4044.138

No I'm not going to get a new phone so I can update stuff.

Is this going to be fixed?

New to the Community?

Start Here