dfoley8255's profile

New Poster


1 Message

Wed, May 6, 2020 7:00 AM

Touchscreen and Keypad compatibility

For the last two weeks, I have been trying to resolve an issue with my touchscreen and keypad.  The system I have is just over 5 years old and up until March was working pretty decent.  In March the touchscreen starts putting out a notification that the batteries on the keypad were going dead.  Cool.  Replaced the batteries.  The notification never resolves itself.  I tried rebooting the touchscreen, I get the same notification. I tried replacing the batteries again, I get the same notification.  Finally, after having to sit at home trying to work and listen to this thing beep every hour, I contact support.  Tech walks me through resetting the touchscreen, no change.  Then we proceed to try and reset the keypad.  They have me go and delete the current keypad and re-add it to the system.  The touchscreen will not locate the keypad.  We try this for an hour and a half to no avail.  Tech suggests that the keypad may be faulty and sends a new one.  Cool.  In the meantime, I am waiting for it to arrive.  I go over the steps from our session to try to get the old keypad to connect for 4 days and nothing.  The new keypad arrived yesterday and I try to connect it following the self install instructions.  Nothing.  I contact support again and they walk me through it.  Still won't work.  Now, the new keypad is very much different from my former keypad.  Given the instructions, the techs walkthrough, and what I can see myself it does appear the keypad itself is in good working order.  The LEDs light up and it does appear to be attempting to connect to the system.  However, at this point, I am convinced that it is the touchscreen that is the issue.  Looking on the xfinity website, the current security touchscreen appears different than mine.  This leads me to assume that possible the new keypad and my old touchscreen are not compatible. 


I don't know if anyone has had any issues with an older system or this particular problem, but any help would be appreciated.






No Responses!

New to the Community?

Start Here