robertsl66's profile

New Poster

 • 

2 Messages

Tue, Dec 1, 2020 8:00 AM

channels are broadcasting in Spanish

audio on some channels are in Spanish

Responses

Accepted Solution

CCTeds

Official Employee

 • 

18.9K Messages

7 m ago

@robertsl66 

 

In most all cases, switching to the SAP feed (Secondary Audio Programming) will change the language or resolve “no audio” issues.

 

- For customers on our X1 platform: https://customer.xfinity.com/help-and-support/cable-tv/x1-audio-output/

 

- If you have a DTA (small cable box) and your remote control has a LANG button on it, press it.

 

- If you have an HD or SD full cable box (non X1 with a blue on-screen guide) :

 

Press the Menu button twice on the Comcast Universal Remote Control. A new screen below will appear, with the top-left option automatically selected.

Use the down-arrow key (above the Info button) to navigate to Setup and press OK/Select (the center key on the remote control in the middle of the 4 arrow/directional buttons).

Use the down-arrow key (above the Info button) to navigate to Audio setup and press OK/Select.

 

The Default Audio Track will default to the first option–Channel default–which is always the channel’s main audio track (unless it was previously changed).

 

Press the right-arrow navigation key to change the audio track. Changing this selection will instantly change the audio.

 

  1. Press once for English 
    2. Press twice for Spanish (Español) OR to activate Video Description (DVS) 
    3. Press three times for French (Français) 
    4. Press four times for Portuguese (Portugues). 
    5. Then press the Exit button (above the Volume button) to resume program viewing

 

Please note: These audio options can only be heard if the program provider or cable channel is providing that additional audio option.

- If the above does not help, look at the remote control for your TV set (not your cable box) to adjust the TVs language settings (sometimes labeled as MTS or SAP on the remote or via your TVs settings menu).

New Poster

 • 

2 Messages

7 m ago

Help!  Channels are broadcasting in Spanish.

CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

7 m ago

Check your SAP settings

New Poster

 • 

5 Messages

6 m ago

I need all channels changed to English.

 

New Poster

 • 

5 Messages

6 m ago

I need to talk to a person. I can’t understand the instructions🤬.

New Poster

 • 

5 Messages

6 m ago

I need all channels in English.

CCTeds

Official Employee

 • 

18.9K Messages

6 m ago

@JaneWesterhold  

 

Apologies for any confusion - for the specific cable boxes listed on your account, below are the instructions: 

 

Press the Menu button twice on the Comcast Remote Control. A new screen below will appear, with the top-left option automatically selected.

Use the down-arrow key (above the Info button) to navigate to Setup and press OK/Select (the center key on the remote control in the middle of the 4 arrow/directional buttons).

Use the down-arrow key (above the Info button) to navigate to Audio setup and press OK/Select.

 

The Default Audio Track will default to the first option–Channel default–which is always the channel’s main audio track (unless it was previously changed).

 

Press the right-arrow navigation key to change the audio track. Changing this selection will instantly change the audio.

 

  1. Press once for English 
    2. Press twice for Spanish (Español) OR to activate Video Description (DVS) 
    3. Press three times for French (Français) 
    4. Press four times for Portuguese (Portugues). 
    5. Then press the Exit button (above the Volume button) to resume program viewing

 

Please note: These audio options can only be heard if the program provider or cable channel is providing that additional audio option.

- If the above does not help, look at the remote control for your TV set (not your cable box) to adjust the TVs language settings (sometimes labeled as MTS or SAP on the remote or via your TVs settings menu).

Visitor

 • 

1 Message

2 m ago

This does not work.  The default audio track is fixed, with no arrows indicating a click for a change.  The default language does not change no matter which arrow or other button I press.  None of the robotic support selections respond to this issue and none of the chat buttons respond to any click.

Official Employee

 • 

213 Messages

Hello, @user_431953, thank you for reaching out in our forum and running through those troubleshooting steps. I would be pretty upset to have to deal with this audio issue over my weekend, so I can only imagine how you're feeling. I can definitely help you with this and I have your back all the way. In order to get started can you please send me a private message to Xfinity Support with your full name and full address by clicking the chat icon in the top right?

Visitor

 • 

2 Messages

@user_431953 

I don't know why they don't tell you but the default won't change to English until you change the  setting below it "descriptive video service " to off. Then you can change the default audio track. No one is telling people this. Hope it helps you.

Visitor

 • 

1 Message

2 m ago

Several channels randomly started playing in Spanish all settings show English however its still playing audio in spanish. We have reset all settings, reset the SAP, updated the box. Nothing has fixed it.

Visitor

 • 

2 Messages

2 d ago

There are many posts that show how to change the default audio track. But a lot of people can't change the setting. The problem is you first must set the descriptive video service right below it to off. Then you can change to English. Hope this helps people that can't get the setting to change.

New to the Community?

Start Here